Filbehandling i Windows

Filbehandling med Windows Explorer

Hva gjør Windows Explorer

Windows Explorer gir deg mulighet til å organisere filene dine i mapper og undermapper, slette filer du ikke ønsker å ha, gi filer og mapper nye navn, åpne dokument, kopiere til/fra disketter osv.

Start Windows Explorer og finn ditt hjemmeområde

Klikk på:

  • Start -> Programs -> Acessories -> Windows Explorer

Eventuelt kan du bruke windowstasten+E som hurtigtast for å komme direkte til My Computer.

  • Her kan du se hvordan Windows Explorer ser ut.

Finn ditt hjemmeområde

  • Dine filer og mapper ligger på det vi kaller ditt hjemmeområde. På MatNat vil du finne det under ditt_brukernavn on platon (M:/). Merk at ikke alle brukere på MatNat ligger på platon, da vil det isteden stå f.eks. ditt_brukernavn on kant (M:/) om ditt hjemmeområde ligger på serveren kant.

Her ser du hvordan du finner ditt hjemmeområde:

Hvordan og hvorfor organisere filer i mapper

Det har lett for å bli mange filer på området ditt, noe som gjør det vanskelig å finne nettopp den filen man ønsker. Det er flere tiltak man kan sette inn mot dette:

Gi gode filnavn

Navnene skal være beskrivende, slik at det er lett å huske hva den inneholder. Navn som bilde.bmp og brev.doc vil være vanskelige å gjette det nøyaktige innholdet av, mens smørblomst.bmp og brevMari14_99.doc er adskillig mer informative.

Les mer om navngivning og hvordan du bytter navn på en fil.

Legg filene i mapper (kataloger).

Hva er mapper?

Mapper er et sorteringssystem for filer. Du samler alle filer som har en egenskap felles (bilder, artikler, forelesningsnotater,..) i en mappe og gir den et beskrivende navn. Inne i mappene kan det også være nye mapper.

Hvordan lage mapper?

Her kan du lære hvordan du lager en mappe, og hvordan du flytter en fil til den mappen du vil ha den i.

Eksempel på filstruktur:

Under ser du en tegning av et sorteringssystem for mine filer. Jeg har valgt å sortere dem i mappene Skole og Arbeid, men det er alltid noe som faller utenfor, og derfor har jeg laget en mappe som rett og slett heter Annet.

I jobben min må jeg til stadighet skrive rapporter, og i stedet for å kalle dem "helserapport.doc", "prog_språk_rapport.doc", "blomsterrapport.doc" og så videre, lager jeg en mappe, rapport, som jeg legger dem i.

En fordel med dette er at jeg da kan gi dem kortere navn fordi jeg ikke lenger trenger å skrive i navnet at det er rapporter. Lenger ned på siden finner du eksempler på filer og mapper sett fra Windows Explorer og fra et Xterm-vindu på Linux.

Under Arbeid har jeg også lyst å legge timelisten min. Siden jeg ikke har noen andre filer som har samme type innhold, lager jeg ikke en ny mappe for bare denne ene filen, men legger den direkte i mappen Arbeid.

Gi gode mappenavn

Det er også viktig å gi gode mappenavn. Det skal være beskrivende, og helst ikke overlappe mappenavn på samme nivå, siden du da kan glemme hvilken mappe du har lagret dem i.

Eksempel på overlappende mappenavn:

Du har en mappe som heter Brev og en som heter Kari. Hvor har du lagret brevet du skrev til Kari?

Her kan du lære hvordan du bytter navn på en mappe.

Rydd på hjemmeområdet ditt.

Mye som ligger der er sannsynligvis ikke aktuelt å ta vare på lengre og kan derfor slettes. Andre filer vil du gjerne ta vare på, men fordi du ikke bruker dem daglig kan det være aktuelt å flytte dem til en diskett, CD eller til en USB penn.

Slik ser eksempelet over ut i Windows Explorer:

Fra et xterm-vindu på linux:

Vi er inne i mappen Arbeid fra eksempelet i teksten over

Huskeregler for navngivning av filer

Lagring

Når du lager et dokument, må du alltid huske å lagre. Dette fordi det du har laget ellers kan gå tapt, for eksempel ved strømbrudd. Lagring skjer oftest ved at du går inn på File-menyen oppe til venstre på programmet, og velger save.

"Fornavn" og "etternavn"

Når du lagrer et dokument må du gi det et navn. Navnet består av et "fornavn" og et "etternavn", adskilt med et punktum: brev_til_kari.doc

Fornavnet er det du som velger. Det er lurt å være nøye med hvilket navn du velger, slik at det kan hjelpe deg til å huske hva innholdet på filen er.

Etternavnet (fil-ekstensjonen) er fastsatt, og du får derfor ikke velge det selv. Av og til legger programmet du har laget dokumentet i selv til dette etternavnet. Ellers må du skrive det. Vanlige forkortelser er .doc, .xls, .ps, .jpg, .ppt osv.

Lengden på fornavnet og særnorske tegn

MatNats programvare er av nyere dato, og takler derfor både særnorske tegn og relativt lange navn. Skal du ha med deg filene til andre maskiner, derimot, kan det være lurt å endre navnet til noe kortere (8 tegn), siden en del operativsystem forlanger at navnene skal være så korte.

Mellomrom

Du bør også unngå mellomrom i filnavnene. I stedet kan du separere ord i navn med stor forbokstav, som i FilnavnPaaDenneFilen.doc, eller understrek, filnavn_paa_en_annen_fil.doc.

Mellomrom gir f.eks. problem hvis du må arbeide med filen fra kommandolinjen på en unix-maskin, da den vil oppfatte hvert ord i navnet som et eget filnavn. (Se figur under)

Filen "Filnavn med mellomrom.doc" ble laget i Word på en av våre Windows-maskiner, men linux-maskinene våre skjønte ikke at det bare var ett filnavn. (Her kan dette løses ved å bruke dobbel apostrof foran og bak navnet når du skriver kommandoer, men det er unødvendig tungvindt).

Lag ny mappe

Start Windows Explorer. Start -> Programs -> Accessories -> Windows Explorer

  • Finn ditt hjemmeområde. På MatNat vil det stå ditt_brukernavn on platon (M:/).

  • Finn det stedet du ønsker å ha en mappe under.

  • Eksempel: Ønsker du å ha en mappe som heter rapporter som skal ligge inne i mappen Skolearbeid, må du finne mappen Skolearbeid og venstreklikke på den for å markere den.

  • Øverst til venstre vil du finne en meny som heter File. Gå inn på den og velg deretter New Folder

  • Nå vil det dukke opp en ny folder i høgre programvinduet. Under folderen står det "New Folder". Bytt navnet til det du ønsker ved å trykke en gang på "New Folder", og deretter skrive det navnet du vil folderen skal ha. For eksempel "rapporter".

Bytte navn på filer og mapper i Windows Explorer

Felles for alle metodene:

  • Start Windows Explorer Start -> Programs -> Accessories -> Windows Explorer

  • Finn filen eller mappen du ønsker å bytte navn på, og marker den.

  • Fortsett så på metode 1, 2 eller 3.

Metode 1, bruk "File"-menyen

  • Gå inn på File-menyen oppe i venstre hjørne av programmet og velg Rename.

  • Nå vil skrivemerket flytte seg til filnavnet, og du kan viske ut det gamle (trykk på Backspace-tasten på tastaturet), og skrive inn det nye.

Metode 2,

  • Trykk F2, skriv nytt navn.

Metode 3, bakgrunnsmeny

  • Legg musmarkøren over filnavnet, og trykk inn høgre musknapp. En meny vil dukke opp.

  • Velg Rename.

  • Nå vil skrivemerket flytte seg til filnavnet, og du kan viske ut det gamle (trykk på Backspace-tasten på tastaturet), og skrive inn det nye.

Flytte filer og mapper i Windows Explorer

Flytte filer kan for eksempel være aktuelt hvis du har lagret en fil på feil sted. Det kan, som mye annet, gjøres på flere måter.

Felles for alle metodene:

  • Start Windows Explorer Start -> Programs -> Accessories -> Windows Explorer

  • Finn filen du ønsker å flytte, og marker den.

Metode 1, bruk "Edit"-menyen

  • Gå inn på Edit-menyen oppe i venstre hjørne av programmet og velg Cut. Filen vil da "blekne".
  • Flytt deg til den mappen du ønsker å flytte filen til og marker den.
  • Gå inn på Edit-menyen igjen og velg Paste.

Metode 2, "klikk og dra"

  • Legg musmarkøren over filen du vil flytte.
  • Trykk inn venstre musknapp og hold den inne.
  • Dra musmarkøren til den mappen filen skal ligge i, til mappen blir markert (blå bakgrunn).
  • Slipp musknappen.

Metode 3, bakgrunnsmeny

  • Legg musmarkøren over filen du vil flytte og høgreklikk. En meny vil dukke opp.
  • Velg Cut fra menyen.
  • Flytt deg til den mappen du ønsker å flytte filen til og marker den.
  • Høyreklikk på bakgrunnen i venstre vindu av programmet, og en ny meny vil dukke opp.
  • Velg Paste fra menyen.

Kopiere filer eller mapper i Windows Explorer

Å kopiere filer betyr å lage et ekstra eksemplar. Kopiering kan gjøres på veldig mange måter, men her vil jeg ta for meg de to forskjellige måter.

Den føste metoden egner seg best for flytting mellom mapper som ligger langt fra hverandre i filstrukturen. Den siste er svært rask hvis mappene ligger nær hverandre.

Felles for alle metodene:

  • Start Windows Explorer Start -> Programs -> Accessories -> Windows Explorer

  • Finn filen du ønsker å kopiere, og marker den.

  • Velg en av metodene under for å fullføre kopieringen.

Metode 1, bruk "Edit"-menyen

  • Gå inn på Edit-menyen oppe i venstre hjørne av programmet og velg Copy.
  • Flytt deg til den mappen du ønsker å flytte filen til og marker den.
  • Gå inn på Edit-menyen igjen og velg Paste.

Metode 2, "klikk og dra"

  • Trykk inn ctrl-tasten på tastaturet (nede til venstre) og hold den inne.
  • Legg musmarkøren over filen du vil flytte.
  • Trykk inn venstre musknapp og hold den inne.
  • Dra musmarkøren til den mappen filen skal ligge i, til mappen blir markert (blå bakgrunn).
  • Slipp musknappen først, og deretter ctrl-tasten.

Figurer fra metode 2:

Slett filer eller mapper

Det er viktig å slette de mappene og filene du ikke bruker lenger, slik at de ikke bruker diskplass. En indikasjon på at du bør slette en fil kan være at det er lenge siden du har arbeidet med den. Det kan du sjekke ved å sortere filene etter datoen de sist ble endret. Les mer om dette her.

Det er flere måter å slette filer og mapper på:

Felles for alle metodene:

  • Start Windows Explorer Start -> Programs -> Accessories -> Windows Explorer

  • Finn filen eller mappen du ønsker å slette, og marker den. Du kan nå velge hvilken metode du vil bruke for å slette den:

Metode 1, bruk tastaturet

Trykk på delete-tasten til høyre på tastaturet.

Metode 2, "klikk og dra" til Recycle Bin

  • Legg musmarkøren over filen du vil slette.
  • Trykk inn venstre musknapp og hold den inne.
  • Dra musmarkøren til Recycle Bin.
  • Slipp musknappen.

Metode 3, "bakgrunnsmeny"

  • Høyreklikk på mappen eller filen. En meny vil komme til syne.

Problem:

Årsak:

Du prøver å slette en fil som samtidig er åpnet i et av programmene du arbeider med.

Løsning: Lukk filen og prøv og slett den på nytt.

Sortere filer i Windows Explorer

Hvis du har mange filer i en mappe, kan det være greit å sortere dem på forskjellige måter for å få bedre oversikt. Man kan sortere filer alfabetisk, etter når de sist ble endret, etter størrelse eller etter filtype (f.eks. MS Word-filer).

Det er to måter å sortere filer på:

Felles for alle metodene:

  • Start Windows Explorer Start -> Programs -> Accessories -> Windows Explorer

  • Finn mappen du vil sortere filer i, og åpne den.

Metode 1, bruk view-menyen

  • Velg View -> Arrange Icons og velg sortering etter ønske

Metode 2, "bakgrunnsmeny"

  • Høyreklikk et sted i mappevinduet der det ikke er noen fil. En meny vil komme til syne:

Man kan også velge hvordan man vil se filene i en mappe fra View menyen. Mulighetene er:

  • Large Icons Hver fil vises som et stort ikon.
  • Small Icons Hver fil vises som et lite ikon.
  • List Ligner på Small Icons, men er gjerne mer oversiktlig
  • Details Ved siden av hver fil vises detaljert informasjon om filen
  • Thumbnails Nyttigst for bildefiler, hver fil vises som en forminsket utgave av hva den inneholder.

Dele filer med andre brukere

Det er dessverre ingen pålitelig måte å dele filer på i Windows, for å gjøre dette er man nødt til å bruke Linux. Hvordan kan du lese om her.

Åpne filer i andre programmer enn standard

  • Start Windows Explorer Start -> Programs -> Accessories -> Windows Explorer

  • Finn filen du ønsker å åpne.

  • Høyreklikk på filen. En meny vil komme til syne.

  • Trykk på <i>Open With...
  • Du vil nå få opp et vindu:

  • Finn programmet i listen, og trykk OK.

Hvordan bruke zip

Zip er et nyttig verktøy som gjør en i stand til å pakke sammen en eller flere filer til en fil og samtidig redusere den totale filstørrelsen. Generelt sett vil man få størst effekt av å komprimere tekstfiler og andre ikke-optimaliserte filtyper.

En komprimert fil har følgende ikon i windows og har filendelsen *.zip.

Her ser man også forskjellen på filstørrelsen mellom den orginale filen og den komprimerte filen.

Zippe en fil gjøres på følgende måte

  • Merk den eller de filene eller mappene du ønsker å zippe.

  • Høyreklikk på de valgte filene og velg Send to -> Compressed (zipped) Folder.

  • Eller velg Fil-> Send To-> Compressed (zipped) Folder.

Resultatet av disse operasjonene vil altid ha samme navn som den orginale filen dersom det bare er en fil (med en zip-endelse) eller filnavnet til en av filnene dersom du velger å zippe flere.

Windows-versjonen som benyttes på termstuene har innbygget forståelse av zippede filer og vil behandle en zippet fil som en mappe. Det vil si at du kan åpne filen og hente ut den eller de filene du er interesert i på den måten som passer deg best.

Du kan også velge å pakke ut hele zip-filen. Da vil du få opp en veiviser som leder deg gjennom prosessen.

Bruk av diskett

  • Sett disketten i maskinen. Som oftes er der en pil på disketten som viser hvilken del som skal stikkes inn først.

  • Start Windows Explorer Start -> Programs -> Accessories -> Windows Explorer

  • Finn symbolet for diskettstasjon og dobbeltklikk på den. Diskettstasjonen finner du under "3 1/2 Floppy(A:/)". ( Her kan du se hvor.)

  • Nå vil innholdet på disketten vises, og du kan åpne filene, slette dem, kopiere og så videre (figur under).

Problem:

Årsak:

Du har ikke satt i disketten. Trykk cancel, sett inn disketten og prøv igjen.

Bruk av CD

  • Sett CD'en i maskinen. Noen av maskinene på termstuene står på høykant, da må du holde CD'en intill sporet når du lukker CD-stasjonen.

  • Start Windows Explorer Start -> Programs -> Accessories -> Windows Explorer

  • Finn symbolet for CD-stasjonen og dobbeltklikk på den. Diskettstasjonen finner du under "Compact Disc (D:\)" ( Her kan du se hvor.)

  • Nå vil innholdet på CD'en vises. CD-ROM er et "read only" medium, og de et er kun mulig å åpne eller kopiere filer fra CD'en, det er ikke mulig å slette eller endre dem på noen måte. Noen av termstuemaskinene har CD-brenner, det kan du lese om her.

Problem:

Årsak:

Du har ikke satt i CD'en. Trykk cancel, sett inn CD'en, og prøv igjen.

Bruk av USB-penn

  • Plugg USB-pennen i en USB-kontakt på maskinen.

  • Start Windows Explorer Start -> Programs -> Accessories -> Windows Explorer

  • Finn symbolet for USB-stasjonen og dobbeltklikk på den. USB-stasjonen finner du under "Removable Disk".

  • Nå vil innholdet på USB-pennen vises, og du kan åpne filene, slette dem, kopiere og så videre.

Koble opp hjemmeområde

Det hender også at hjemmeområder ikke kommer opp automatisk når man logger seg inn, og da er det greit å vite hvordan man kan få det opp selv. Noen ganger kan det også være praktisk å kunne se på andre brukeres hjemmeområde, f.eks. hvis den andre brukeren vil dele en fil med deg. For å gjøre disse tingen så må man koble til en nettverksstasjon.

  • Start Windows Explorer Start -> Programs -> Accessories -> Windows Explorer

  • I menyen, velg Tools -> Map Network Drive.

  • Du vil nå få opp dette vinduet:

  • Velg hvilken stasjonsbokstav du vil at den nye stasjonen skal få. Hvis du skal koble opp ditt eget hjemmeområde så bør den få bokstaven M:

  • Hvis du skal koble til et hjemmeområde, skriver du \\samba\dittbrukernavn\ i rubrikken merket "Folder". I bildet over er vi i ferd med å koble til brukeren "ivers" hjemmeområde som stasjon K:

  • Hvis du skal koble til en stasjone eller et område på en annen maskin, skriver du \\maskinnavn\områdenavn , for eksempel \\mnstudpc314\zip\ . Eventuellt, hvis du er usikker på navnet kan du klikke på "browse" knappen, for å bla gjennom tilgjengelige maskiner, men siden det er ganske

mange datamaskiner ved UIO er dette noe uoversiktlig.

  • Hvis du vil at nettverksstasjonen skal kobles opp automatisk neste gang du logger deg inn på denne maskinen, haker du av i feltet "Reconnect at logon".

Hvordan få tilbake filer som er slettet/mistet?

Du husker ikke at du har slettet den

  • 1. Lagret du den "på maskinen", eller kanskje du hadde den på diskett eller på CD? Sjekk disketter og CDer hvis du tror det er mulig å finne den der.

  • 2. Søk etter filen du har mistet.

  • Start Windows Explorer Start -> Programs -> Accessories -> Windows Explorer

  • Finn hjemmeområdet ditt. Det heter ditt_brukernavn on 'platon' (M:). Klikk her for å se hvordan det ser ut.

  • Klikk så en gang med høyre mustast på ditt_brukernavn on 'platon' (M:) og klikk med venstre mustast på "Search".

  • Skriv inn navnet på filen du ser etter i boksen under "All or part of the file name". Under "Look in:" er allerede ditt hjemmeområde valgt, så denne trenger du ikke endre. Klikk så "Search"-knappen.

  • Etterpå vil de filene som matcher med ditt søkeord vise seg til høyre i Windows Explorer-vinduet. Da vil du se navnet på filen under "Name", og hvor filen ligger under "In Folder". Her eksemplifisert ved å søke på mbv hos min egen bruker.

  • Finner du ikke filen, og du opprettet filen i dag er den dessverre borte. Er det derimot en eldre fil du søker etter har USIT backup av denne filen.

Backup er tatt av filen din

En backup av en fil eller et filområde er en sikkerhetskopi som man tar vare på i tilfelle det skulle skje noe med orginalen. På UiO blir det tatt backup av alle brukerdisker hver eneste natt. Så hvis filen du ser etter er mer enn en dag gammel har USIT en kopi av filen i sitt backupsystem.

  • 3. For å få tilbake en fil, må du sende e-post til restore@usit.uio.no. De vil da be

om opplysninger som hva filen het, hvor den lå og når den ble mistet.

  • 4. Du kan også gjøre hente tapte filer selv ved å gå inn på linux, og finne filen via [snapshot snapshot].