Maple
Maple er et matematikkprogram som kan brukes til både helt enkle og til mer avanserte matematiske oppgaver. Denne veiledningen er bygget opp på følgende måte:
- Starte Maple
- Når du er helt nybegynner i Maple
- Hjelp-funksjoner i Maple
- Forskjellige matematiske kommandoer i Maple:
- Noen tips
- Linker til andre sider om Maple
Starte Maple
For å starte Maple velger du
Start > Programs > Maple 9.5 > Maple 9.5
Hvis maskinen har en annen versjon av Maple installert, vil det kanskje stå et litt annet tall etter 'Maple', men det er nok også den eneste store forskjellen.
Når du er helt nybegynner i Maple
Maple er et matematikkprogram. Det vil si at du kan bruke Maple til alt som du ellers ville brukt en kalkulator til, og mere til. For eksempel kan du bruke Maple til å lage tredimensjonale grafiske framstillinger, regne ut funksjoner, forenkle uttrykk osv.
Første gang du bruker Maple, anbefaler vi deg sterkt å gå gjennom hele Maples egne omvisningstur. Den finner du i Maple ved å velge
Help -> New Users -> Quick Tour
Denne omvisningen vil gi deg en grunnleggende innføring i Maple.
Når du starter Maple, vil det komme opp et nesten blankt 'ark', sånn som dette:

Det lille tegnet øverst til venstre på arket, kalles et prompt Et prompt er et (hvilketsomhelst) tegn/symbol som indikerer at programmet/maskinen er klar til å ta imot input.
For å bruke Maple, må du nemlig skrive uttrykk for det du ønsker at Maple skal gjøre. Dette uttrykket skriver du i form av en kommando på linjen som promptet 'peker' på.
Et uttrykk kan være noe så enkelt som f.eks regnestykket 2+3. Når du så trykker enter, vil Maple behandle uttrykket du har skrevet ned. Se eksempel i figur under.
NB Et uttrykk skal (nesten) alltid avsluttes med en ;(semikolon).

Maple har sin egen syntaks som du må bruke for at Maple skal skjønne hva du ønsker å gjøre.
Å lære Maple handler derfor mye om å lære seg Maples språk og syntaks.
På det grå feltet til venstre på Maple-vinduet, ser du en rekke med paletter (Expres, Symbol, Matrix, Vector). Disse er svært nyttige redskap for å guide deg til å bruke riktig syntaks når du skal bruke forskjellige matematiske kommandoer og funksjoner.
Hvis du har skrevet et uttrykk på feil måte (feil syntaks), vil Maple gi deg en feilmelding. Som oftest viser denne feilmeldingen nokså tydelig hvor feilen ligger.
Et uttrykk skal som nevnt nesten alltid avsluttes med en ; (semikolon). I eldre Maple-versjoner vil du få en feilmelding som forteller deg at du mangler en semikolon, og du må skrive uttrykket på nytt, denne gangen med semikolon. I Maple 9.5 vil imidlertid uttrykket ofte behandles på tross av at semikolon mangler. Du vil istedet få en advarsel. Se eksempel under

Avsnittet Forskjellige matematiske kommandoer og funksjoner går gjennom en del av de enkleste uttrykkene/funksjonene som man kan bruke i Maple.
Hjelp-funksjoner i Maple
- I Help-menyen finner du eksempler og annen hjelp som kan være nyttige.
- Du kan også gå til Help->Topic search og søke etter akkurat den funksjonen du trenger hjelp til.
- Maples egen introduksjonstur finner du på Help -> New Users -> Quick Tour . Her blir alt viktig gjennomgått.
- De matematiske funksjonene kan du få hjelp med ved å skrive ??kommandonavn eller ?kommandonavn. Da popper det opp et nytt lite vindu med informasjon om kommandonavnet. Se eksempel i figuren under :

Forskjellige matematiske kommandoer og funksjoner i Maple
Maple inneholder mange funksjoner og hjelpemidler, i det følgende er de viktigste gjennomgått.
- Aritmetiske operasjoner (plusse, gange, kvadrere..)
- Innebygde konstanter i Maple
- Innebygde funksjoner i Maple
- Tilegne en variabel en verdi
- Tilegne og plotte en funksjon
- Vektorer
- Matriser
Aritmetiske operasjoner (plusse, gange, kvadrere..)
| Aritmetisk operasjon | Hva du skal bruke i Maple |
|---|---|
| Multiplikasjon | Bruk alltid * mellom to verdier som skal multipliseres. For hånd ville du kanskje skrevet et uttrykk som f.eks 47x, men i Maple må du altså huske å skrive det som 47*x. |
| Addisjon | Bruk vanlig + |
| Divisjon | Bruk vanlig / |
| Subtraksjon | Bruk vanlig - |
| Potenser | Bruk ^. Eksempel: For å skrive x opphøyd i andre, skriver du x^2. |
| Kvadratrot | Bruk sqrt. Eksempel, roten av fire: sqrt(4) |
Det er viktig å huske å bruke parenteser hvis du har et sammensatt uttrykk. Maple bruker de vanlige lovene om hvilken rekkefølger operasjoner blir utført. Det vil f.eks si at multiplikasjon går foran addisjon. Hvis du f.eks har sammensatte brøker, må du huske parenteser for å få dette riktig.
Maple gir deg alltid det eksakte svaret, det vil si ofte en brøk. For å få et desimalsvar kan du bruke funksjonen evalf. Se eventuelt eksempel under Tips lenger ned.
Innebygde konstanter i Maple
| Konstant | Verdi | Forklaring | Hvordan 'skrive' i Maple |
|---|---|---|---|
| π | 3.141592.. | Forholdet mellom en sirkels omkrets og diameter | Pi |
| e | Den naturlige eksponent | 2.71828... | exp(1) |
| i | i=√-1 | Imaginære tall | I |
| ∞ | ∞ | Uendelig | infinity |
Innebygde funksjoner i Maple
| funksjon | Eksempel | Uttrykk i Maple |
|---|---|---|
| Naturlig logaritme | ln(x) | ln(x) |
| Logaritmen med grunntall a | logax | log[a](x) |
| Absoluttverdi | |x| | abs(x) |
| Kvadratrot | √x | sqrt(x) |
| Trigonometriske funksjoner | sin(x),cos(x),..., arcsinh(x).. | sin(x),cos(x),...,arcsinh(x)... Husk at Maple for alle vinkler bruker radianer |
Tilegne en variabel en verdi
Av og til er det greit å bruke et variabelnavn istedet for selve variabelen.
Bruk := for å tilegne, og unassign for å fjerne tilegningen igjen, se eksempelet under:

Tilegne og plotte en funksjon
For å definere en funksjon, for eksempel f(x), bruker man følgende syntaks f:=x-><funksjon>
der du bytter ut <funksjon> med det uttrykket du vil funksjonen din skal være lik.
For å plotte en graf av funksjonen bruker du plot(f(x));
Her er det viktig å si fra hvilket område du ønsker at grafen skal spenne seg over, ellers vil det ofte komme en feilmelding om at regionen er for stor. I eksempelet under strekker både y- og x-aksen seg over ±10

Du kan også plotte en funksjon direkte, uten å ha tilegnet den et funksjonsnavn først. Altså ville du fått nøyaktig samme graf i eksempelet over, dersom du istedet hadde skrevet kommandoen
plot (x^2, x=-10..10, y=-10..10);
Vektorer
Vektorer uttrykker du ved hjelp av klammeparanteser ([ ]) og komma mellom tallene. Se eksempel under:

Når du regner med vektorer og matriser, vil du får bruk for en ekstra Maple-pakke for lineær algebra. Pakken heter linalg, og de funksjonene du vil få mest bruk for er nok prikkprodukt og kryssprodukt. Man impoerterer en pakke i maple ved å skrive import(pakkenavn); I neste figur viser bruk av dette.

Imidlertid har Maple paletter som kan hjelpe deg når du skal skrive vektorer, slik at du får hjelp til å huske hvilken syntaks du skal bruke. Klikk på knappen det står 'Vectors' på til venstre, og velg riktig 'fasong'.
Matriser
Matriser uttrykkes også ved hjelp av klammeparanteser, nokså likt som vektorer - bare litt mer komplisert. I eksempelet nedenfor har vi skrevet opp en nokså enkel matrise. Du kan også bruke en palett fra menyen til venstre når du skal sette opp en matrise.

Husk vanlige paranteser rundt hele uttrykket, samt klammeparanteser rundt både matrisen og hver enkeltrekke. Siden matriser blir nokså kompliserte å skrive opp, er det veldig smart å tilegne dem variabelnavn når du skal regne med matrisene.Se eksempelet nedenfor
For å regne med matriser må du også bruke en funksjon som heter evalm (kommer av "evaluate matrice") for at Maple skal skjønne at det er matriser den regner med.

Forskjellige matematiske operasjoner på matriser vises i neste eksempel:

Også for matriser er pakken linalg svært nyttig. Når du henter denne pakken, får du tilgang til en rekke funksjoner for lineær algebra. Se eksempler:
Noen tips
- Bruk parenteser ofte, helst rundt hvert eneste ledd i et uttrykk for å unngå feil.

- Du kan bruke # som et kommentatortegn. Etter # blir ingenting på linja registrert.
- Du kan bruke % som representasjon for den siste utregningens resultat. Dette kan være praktisk, men kan også gjøre regnestykkene svært uoversiktelige.

- Husk alltid multiplikasjonstegn * mellom to tegn som skal multipliseres.
- Maple gir deg eksakte resultat som svar. Hvis du istedet vil ha desimalverdier kan du bruke evalf rundt uttrykket.
- For å forenkle et uttrykk, kan du skrive simplify.
- Maple er case-sensitive, pass derfor på at du bruker små og store bokstaver korrekt.

- For å legge til ekstra pakker, skriv with(pakkenavn).
Paletter kan forenkle bruken av Maple. Det er tre av dem; Expression, Matrix og Symbol. De kan åpnes under
View->Palettes
Her kan du f.eks velge greske bokstaver, matriser og en del matematiske snarveier. Prøv deg frem på egen hånd.