![]() |
Domene-navnetjenesten (DNS) er en verdensomspennende katalogtjeneste for registrering av datamaskiner med adresse, domene-del av elektroniske postadresser osv. Datamaskiner foretar automatisk oppslag i denne katalogen, og DNS benyttes hyppig av de andre datanett-tjenestene. Blant annet er DNS en forutsetning for at elektronisk post skal virke slik vi kjenner denne tjenesten. Ved en telling foretatt av RIPE i januar 2000 var det registrert 10 276 963 maskiner i de landene RIPE administrerer IP-adresser (Europa pluss noen til), 438 961 i Norge, hvorav omlag 6000 ved UiTø. IT-avdelingen administrerer universitetets adresserom i domene-navnetjenesten (uit.no), og driver registrerings- og oppslagstjeneste for universitetet. Omlag førti underdomener er registrert. IT-avdelingen driver også såkalt sekundærtjener for flere av de regionale UNINETT-medlemmene. Hva brukes DNS tilMennesker foretrekker å operere med navn på ting, mens datamaskiner oftest benytter tall for å refere til objekter. Når ei datamaskin mottar kommandoer som "telnet levis.uit.no" eller "ftp nic.funet.fi", kan DNS oversette navnet brukeren oppgir til en IP-adresse som maskina kan bruke til å opprette forbindelsen. Siden DNS er en tjeneste "på nettet" må maskiner som skal bruke tjenesten tilknyttes lokalnettet og konfigureres til å bruke IP før det er meningsfullt å snakke om bruk av DNS. Når slik IP-konfigurering er i orden vil de fleste TCP/IP-baserte nett-tjenestene kunne benytte DNS. Det er også verdt å nevne at det fins et dokument som gir gode (!) råd om å gi navn til datamaskiner. De viktigste rådene kan oppsummeres til
Det finnes flere verktøy for å se opplysninger som er registrert i DNS. Det mest kjente programmet som finnes på flest plattformer heter nslookup. Andre programmer (som gir mer korrekte svar er dig og host. Det finnes også ei webside som lar deg se hva som er registrert i et spesielt domene. Konfigurering av UNIX-maskiner som skal bruke DNSFor at UNIX-maskiner (tjenermaskiner og arbeidsstasjoner) skal benytte DNS, må fila /etc/resolv.conf opprettes på maskina, med følgende innhold: domain subdomene.uit.no nameserver 129.242.4.254 nameserver 129.242.5.254 hvor "subdomene" skal endres. Spør hostmaster@uit.no eller ring IT-avdelingen hvis du er i tvil om domene-navnet. Videre konfigurering varierer med hvilken Unix-variant maskina benytter
Slutten av kapittel 6 i Albitz/Liu inneholder mer detaljert informasjon, og behandler også Suns Solaris, IBMs AIX, Silicon Graphics' Irix, SCO's Open Server 5.0, Linux, Windows 95 og Windows NT Programvare for å gjøre interaktive oppslag i DNS fins i flere varianter, f.eks. nslookup (følger med de fleste Unix-versjoner), dig og host. Kildekoden til de to siste er tilgjengelig fra flere ftp-tjenere på Internet. Litteratur om DNS ("teknisk")DNS er spesifisert i RFC 1035, og den bakenforliggende filosofien er gjennomgått i RFC 1034. Kapittel 6 i RFC 1123 handler om krav til DNS-implementasjoner. RFC 2181 oppklarer en del uklarheter i de tre foregående RFC'ene. RFC 1535 beskriver et potensielt sikkerhetsproblem ved resolver-programvare. RFC 1033 beskriver forhold omkring konfigurering og drift av egen navnetjener. Denne informasjonen kan man også finne i Albitz/Liu (lettere tilgjenglig). RFC 1536 og RFC 1537 beskriver feil og problemer som ofte oppstår når en driver egen navnetjener. Kapitlet "The Domain Name System" i Comers bok er også en brukbar introduksjon til DNS. Noen andre mer eller mindre relevante dokumenter om DNS er RFC 920, RFC 974 (bruk av DNS til epost-ruting), RFC 1101 (nettverksnavn), RFC 1183, RFC 1706 (NSAP) RFC 1383 og RFC 1464 (koding av vilkårlig informasjon i DNS). RFC 1498 tar opp mer generelle forhold ved navngiving i datanett, mens RFC 1876 beskriver hvordan opplysninger om geografisk plassering (geografiske koordinater) kan legges i DNS. RFC 2052 og RFC 2219 tar for seg ulike måter å legge opplysninger om nettverkstjenester inn i DNS. Følgende RFC'er handler om virkemåten til selve programvaren: RFC 1982 (serienummeraritmetikk), RFC 1995 (inkrementell soneoverføring), RFC 1996 (notifisering om soneendringer), RFC 2065 og RFC 2535 (sikkerhetsutvidelser), RFC 2136 (dynamiske oppdateringer), RFC 2137 (sikre dynamiske oppdateringer), RFC 2182 (sekundære navnetjenere), RFC 2238 (negativ caching av forespørsler), RFC 2317 (klasseløs IN-ADDR.ARPA delegering) og RFC 2671 (utvidelsesmekanismer for DNS). Skal man installere en DNS-tjener, inneholder Albitz/Liu informasjon om det også. Men vær oppmerksom på at programvaren bind fins (minst) i versjon 4.9.8 og 8.3.1. For den sin drifter en bind navnetjener kan denne sida være nyttig når det gjelder å finne ut hva alle meldingene i syslog betyr. Spørsmål om domenenavn og delegering av autoritet for DNS-soner kan rettes til <hostmaster@uit.no> eller <hostmaster@uninett.no>
|