English Ansatte Kontakt Send epost Intranett
Aktuelt Studier/Opptak Om høgskolen Student Bibliotek IT-drift
 
Avdeling for informasjonsteknologi Datautdanning Avdeling for helse og sosialfag Helse- og sosialfag Avdeling for ingeniør- og realfag Ingeniørutdanning Avdeling for lærerutdanning Lærerutdanning Avdeling for samfunnsfag og fremmedspråk Samf.fag, økonomi og språk Akademi for scenekunst Scenekunst Videreutdanning
 
KONTAKTINFO

Høgskolen i Østfold
Avdeling for informasjonsteknologi
Remmen
1757 Halden
Tlf. 69 21 53 00
Fax 69 21 53 02

post-it@hiof.no

 
 
  Fag ITF20205 - Datakommunikasjon
 

  Velkommen til fagsiden for ITF20205:  Datakommunikasjon

  

Dette faget er obligatorisk for 2. klasse studentene i bachelorstudiene informatikk og ingeniørfag data.

  • Mål
    Studentene skal tilegne seg kunnskap om forskjellige overføringsmedia og kommunikasjonsprotokoller som brukes i datakommunikasjon. De skal også tilegne seg kunnskap om de forskjellige lagene i protokoll-stack'en, og vite hvordan den kunnskap kan brukes ved oppsett av datanettverk. Studentene skal kunne sette opp og konfigurere lokale datanettverk. Det blir fokus mot det som brukes i Internet.

  • Innhold
    De grunnleggende karakteristikkene på forskjellige overføringsmedia. Elektriske og fiberoptiske kabler, radio. Overføringsmetoder brukt på de forskjellige media, slik som digital koding, baseband og modulasjon. Funksjonene til de forskjellige lag i protokoll-stack'en, fra lag 1 opp til og med lag 4. LAN, WAN, Wireless. Ethernet, IP, TCP, UDP. Subnetting. Ruting. ISDN. ADSL. Protokollers oppbygging og virkemåte. Feilkontroll, Kompresjon, Flytkontroll.

    Nettverkskomponenter; Switch, HUB og Ruter. Konfigurasjon av Cisco-rutere brukt i et datanett. DNS og DHCP.

Litteratur :
• "Computer Networking and the Internet" av Fred Halsall.   ISBN 0-321-26358-8.
• Kompendier.

 
Personale :
• Erling Strand
• Geir Strøm
• Leif M. Nielsen
• Stud.ass: Espen Polanscak

Hjelpemidler til eksamen:
• 4 sider (A4) (2 ark) med egne notater.
• Kalkulator.
• Din ZigBee besvarelse (deles ut på eksamen).

ITF20205 LINKER

Fagbeskrivelsen
Hovedsiden
Timeoversikt
Innleveringer
Oppgaver

 
GENERELLE LINKER

Intro to datacom

Internet's fødsel
Internets historie

 
MEDIA- OG GRENSESNITT

Cat5, Cat6..FAQ
Cat6 (1), (2), (3)
Installing Cat6
Cat6 intro

Connector spec

Fiber Guide
Fiber-Optic technologies
Fiber-Optic cable
Numeric Aperture

RS 232

QAM (1), (2)
ADSL

Bluetooth
Bluetooth film (30min)
ZigBee


 
PROTOKOLLER OG DATANETT

Transportlaget
Network definitions
Network Devices
Intro to TCP/IP
TCP/IP Tutorial
IP

Portnummer

IANA
RFC

Portnummer
Sockets
Sockets Programming

NAT
NAT (RFC 1631)
NAT adresser (RFC 1597)
NAT (RFC3022)

DHCP
DHCP (Linux)

RIP (RFC 1058)
RIP2 (RFC 2453)

SMTF (RFC 821)

Cisco ios

IP-film (124Mbyte!)

Network-tools

 
Oppdatert av Erling Strand  27.08.2006
Ved feil/mangler - kontakt: Erling Strand
Høgskolen i ØstfoldStudentsamskipnaden i ØstfoldStudentorganisasjonen i Østfold