Oblig 5 (ITM30408)
Fra Hiofwiki
Trekk pusten godt.
Pust sakte ut.
RFC-er kan være komplekse, men er garantert overkommelige.
RFC-er
Gruppene velger RFC-er under forelesningen fredag 3.4.
- Gruppe 1: RFC 1305
- Gruppe 2: RFC 3920
- Gruppe 3: RFC 2131
- Gruppe 4: RFC 114
- Gruppe 5: RFC 3501
- Gruppe 6: RFC 1149 + RFC 2549 + RFC 3251
Presentasjonen
Hver gruppe har 45 minutter til disposisjon, inkludert 15 minutter til spørsmål. Presenter så godt dere kan de viktigste aspektene av protokollen gruppa har valgt. RFC-ene som velges blir pensum til eksamen.
Pedagogisk framstilling og kreativet trekker opp. Lange punktlister vist på prosjektør trekker ned. Velg medie(r) og metode(r) dere selv synes passer best. Med mindre det gode grunner finnes, skal alle på gruppa delta i presentasjonen.
Forslag til områder som bør dekkes:
- Beskriv hva protokollen gjør, og hvilke ting den vanligvis brukes til.
- Indiker hvor utbredt protokollen er.
- Hvordan møter vanlige brukere protokollen?
- Vis gjerne eksempler på hvordan protokollen brukes og/eller fungerer.
- Hvem var med på å forfatte protokollen? Hvilke firmaer var forfatterne ansatt i?
- Hvilke tilsvarende og/eller konkurrerende protokoller finnes? Ta også i betraktning protokoller som ikke er standardisert av IETF.
- Hvordan har protokollen utviklet seg? Hvilke eldre RFC-er er den eventuelt basert på?
- Utvikles protokollen fremdeles aktivt? Hvilke planer finnes for videreutvikling?
- Bruk gjerne andre kilder, men husk at RFC-en deres er det sentrale emnet
- Prioriter hvilke detaljer dere behandler grundig, raskt eller ikke i det hele tatt
- Samarbeid gjerne med andre grupper som har valgt tilgrensende RFC-er
Plan
Ta kontakt hvis du lurer på noe eller trenger tips.
RFC-ene presenteres fredag 24.4.
Lykke til!
